2009-05-12

GnuTLS のインストール

 
gnutls-2.6.6.tar.bz2
cd /usr/local/src
wget ftp://ftp.gnupg.org/gcrypt/gnutls/gnutls-2.6.6.tar.bz2
tar -jxvf gnutls-2.6.6.tar.bz2
cd /usr/local/src/gnutls-2.6.6
./configure --prefix=/usr/local
make
make install



備考

gnutls-2.6.6 + libcrypt-1.2.4 ではコンパイルエラーがでた。
mac-libgcrypt.c:123: error: 'GCRY_MD_SHA224' undeclared (first use in this function)

該当箇所をコメントアウトしてコンパイルすれば問題なさ気なのだけれどもそれはどうかわからない。
gnutls-2.6.6 + libcrypt-1.4.4 だと問題ない。



環境
#cat /etc/redhat-release
CentOS release 5 (Final)

 

0 件のコメント:

コメントを投稿